主题:【原创】关于耶拿ZEEnit700P标配软件Aspect LS 1.4.2.0中文版的BUG

浏览 |回复12 电梯直达
lhman
结帖率:
100%
关注:0 |粉丝:0
新手级: 新兵
用耶拿的仪器也将近两年了,自动化仪器给予我们很多便利,省去人工计算的繁琐,但有时也让人抓狂。
以下列举一个计算方法的BUG,相信用过ZEEnit700P的用户都明白,这也是我无意操作失误发现的,供大家参考:
正常操作:

上图单位改为“mg/kg”
点击”样品ID→分析序列”生成下图

点击绿色双箭头运行分析序列后

其计算方法为:结果(浓度2)=C1×V定容/m×1000-C空白/1000
非正常操作:

注:单位为“ug/L”
点击“样品ID→分析序列”生成分析序列

点击绿色双箭头运行分析序列

此时,点软件界面“分析序列样品”打开分析序列,点击“样品ID”改样品单位“ug/L”为“mg/kg”如下图:

点击“样品ID→分析序列”→关闭“样品ID”→点“OK”让分许序列继续运行
运行结果如下图:

发现会出现红色提示错误 “1392空白单位不匹配”,但分析序列仍在运行没有终止。

然而计算结果后会惊人的发现与国标计算公式如出一辙
结果值计算公式为:结果(浓度2)=(C样品-C空白)×V定容 /m×1000
欢迎大家参与讨论,并批评指正!!!
为您推荐
推荐帖
Last edit by lhman 举报
qlmkk
结帖率:
100%
关注:0 |粉丝:0
新手级: 新兵
lhman
结帖率:
100%
关注:0 |粉丝:0
新手级: 新兵
原文由qlmkk(qlmkk)发表:结果呢?最终结果哪个对?
正常操作结果靠谱,更接近标准值。
qlmkk
结帖率:
100%
关注:0 |粉丝:0
新手级: 新兵
原文由 lhman(lhman) 发表:
正常操作结果靠谱,更接近标准值。
这个问题已经在后续的版本中更新了,出现1392错误提示后,不会再运行了,楼主还是更新一下软件吧
qlmkk
结帖率:
100%
关注:0 |粉丝:0
新手级: 新兵
lhman
结帖率:
100%
关注:0 |粉丝:0
新手级: 新兵
原文由qlmkk(qlmkk)发表:现在都用1.5.0.0版本了
问一下,1.5.00版本,结果值(浓度2)可以直接进行保留2有效数字的修约功能吗?
qlmkk
结帖率:
100%
关注:0 |粉丝:0
新手级: 新兵
原文由 lhman(lhman) 发表:
问一下,1.5.00版本,结果值(浓度2)可以直接进行保留2有效数字的修约功能吗?
这一点会让你失望了,没有改进,所以你的那个原始记录表格还得手工更改数据
lhman
结帖率:
100%
关注:0 |粉丝:0
新手级: 新兵
原文由 qlmkk(qlmkk) 发表:
这一点会让你失望了,没有改进,所以你的那个原始记录表格还得手工更改数据


试了LS1.5.0.0英文版,结果还是一样,并没有改进。
qlmkk
结帖率:
100%
关注:0 |粉丝:0
新手级: 新兵
我模拟了一下,你说的这个情况,如果一开始,你的设置没有问题,是不会报错的。即使设置有问题,报错后,仪器是不会往下运行的。运行开始后,你人为的制造了一个错误,将样品ID中空白与样品的单位改成不一致,才会造成现在的情况出现。
lhman
结帖率:
100%
关注:0 |粉丝:0
新手级: 新兵
原文由 qlmkk(qlmkk) 发表:
我模拟了一下,你说的这个情况,如果一开始,你的设置没有问题,是不会报错的。即使设置有问题,报错后,仪器是不会往下运行的。运行开始后,你人为的制造了一个错误,将样品ID中空白与样品的单位改成不一致,才会造成现在的情况出现。
说是人为的错误没毛病,不明白的是将错就错后的结果有条有理,数据并没有紊乱,更惊人的是与国标公式一样,让人不得不产生好奇。
sdlzkw007
结帖率:
100%
关注:0 |粉丝:0
新手级: 新兵